[mcstas-users] openmpi compilation problem

Jean-Francois.Moulin at hzg.de Jean-Francois.Moulin at hzg.de
Wed Jun 13 17:36:37 CEST 2012

Hi to all!

new Linux distro, new problem! On Linux Mint 13 I do not manage to install due to mpi problems. As already suggested some months ago I installed openmpi (packages from Ubuntu repos: libopenmpi and its dev).
The ./configure tells me that :
checking mpi.h presence... no
checking for mpi.h... no
WARNING: /usr/bin/mpicc may fail to compile without mpi.h

but I find this on my system:
After reading the output of configure -h, I tried
 ./configure -I/usr/lib/openmpi/include/:
configure: error: unrecognized option: `-I'
I tried putting this path in the cppflags envirt variable. To no avail.
seems I miss the point.
Since I get a Makefile I looked for an include section where I could manually put the path but that does not look so easy... (for me)

second question I am on a 64 bit machine, I should thus configure --with-pic right?

Thanks in advance for your help!



Helmholtz Zentrum Geesthacht
Institut für Werkstoffforschung
Abteilung WPN, Instrument REFSANS
Lichtenbergstr. 1
85747 Garching FRM II
Tel.: +49 (0)89 289 10762
Internet: http://www.frm2.tum.deHelmholtz-Zentrum Geesthacht 
Zentrum für Material- und Küstenforschung GmbH 
Max-Planck-Straße 1 I 21502 Geesthacht I Deutschland/Germany 

Geschäftsführer/Board of Management: Prof. Dr. Wolfgang Kaysser, Dipl.-Ing. Michael Ganß 
Vorsitzender des Aufsichtsrates/Chairman of the Supervisory Board: MinDirig Wilfried Kraus 
Amtsgericht Lübeck HRB 285 GE (Register Court) 
Internet: http://www.hzg.de  

More information about the mcstas-users mailing list