[mcstas-users] rssa source file

Santiago Gómez sgomez at cab.cnea.gov.ar
Tue Sep 11 01:13:18 CEST 2018


I am trying to read a rssa source file (generated with SSW card in MCNP5 
v1.6) with the component Virtual_mcnp_ss_input.comp using the instrument 
file Test_SSW_SSR.instr, but i get this error message:

Instrument parameters for test_SSW_SSR (source.instr)
[test_SSW_SSR] Initialize
MCNP_input: testread: opening MCNP SSW file 'rssa' )
At line 63 of file neutronics-subs.f (unit = 123, file = 'rssa')
Fortran runtime error: I/O past end of record on unformatted file

I also get the same error with a rssa source file generate by MCNP6 

I did the compilation of the neutronics-subs.o file with gfortran 
version 4.8.3.

Can any one help?

I saw in the maillis a similar issue reported with 
Virtual_mcnp_ss_input.comp and fortran compiler, and a possible solution 
proposed by Peter Willendrup was to convert SSW to MCPL.

I tried this and it is working good, but I would like know if it is 
better to keep using converted MCPL than SSW MCNP source files?

Best regards

Santiago Miguel Gómez
Departamento de Física de Reactores y Radiaciones
Centro Atómico Bariloche
Int.: 5971

"Si queremos un mundo de paz y de justicia hay que poner decididamente 
inteligencia al servicio del amor." Antoine de Saint-Exupery

More information about the mcstas-users mailing list